Skip to Global Navigation | Skip to Contents
You're not logged in: Login

Use WebsiteManager
This is an archived document, which may contain out-dated information
Archived documents are still available, but are no longer updated and may contain out-dated information. The EEE team generally cannot provide additional assistance with these topics.

General Information

Netscape Composer 7.0

Netscape Composer 7.0

Composer is no longer supported by Netscape. For more information, see SeaMonkey. However, here are some other online resources that may be helpful.

Links to external websites are not affiliated with UCI.

MATERIALS

What You Will Need

You will need:

  • Netscape Communicator running on a Mac or PC:
      Download:
    • NACS PC Archive or NACS Mac Archive - versions up to 7.0
      (To download programs from the PC or Mac Archives, you will need to connect from a UCI host, either on campus, from the UCI modem pool or through ZOTNet.)
    • Netscape.com
      Note: Before publishing, please download the latest version of Netscape 7 or later.Netscape 6 does not support any publishing features.
  • Content: Documents and images you wish to use.
  • AdvancedWebspace on EEE:
    1. Login to EEE.
    2. On your MyEEE page, find the class.
    3. Click WebsiteManager.
      image of website manager link
    4. Click AdvancedWebspace.
      image of advancedwebspace
    5. Review the on-screen instructions.
    6. Select and confirm an SFTP password if desired. What is SFTP?
    7. Click Request Advanced Webspace.
      image of submit request
    8. Print the confirmation page for you records.
You should receive an email notification that your AdvancedWebspace account has been created within an hour.

7 Steps to Creating Your Web Page

Step 1 — Creating or Editing a Web Page

Note: The index.html file is the homepage in your course directory. When students visit your website, they will automatically be directed to your index.html file. If this file is missing, all the contents of your directory will be displayed as a list.

Creating a new web page

  1. Go to the File menu in the toolbar and choose New > Composer Page.
  2. Go to File > Save As.
  3. Enter a page title.
  4. In the 'Save as type' box, choose HTML Files.
  5. Name the file. (Remember to use index.html if this is your homepage).
  6. Save to a folder on your computer specifically for your website materials.

Modifying your EEE template

  1. Use Netscape to view your EEE course web page on the Web.
    Your course web address on EEE is:
    https://eee.uci.edu/yyq/ccode/
    Where yyq is the year and quarter; and ccode is the 5-digit course code.
  2. Go to File > Edit Page.
  3. Go to File > Save.
  4. Save to a folder on your computer specifically for your website materials.

Modifying an existing web page on your computer

  1. Go to File > Open Web Location....
  2. At the option to Open in: select New Composer window.
  3. Click on Choose File... and a new dialog box will appear.
  4. Browse and select the file you want to modify and click Open.
  5. Go to File > Save.
  6. Save to a folder on your computer specifically for your website materials.

For more help creating a web page, see some helpful links for Netscape Composer

Step 2 — Editing & Formatting Text and Page Properties

Text Formatting

text formatting
The toolbar buttons in the editor window are used to change the formatting of text. Highlight the text you want to edit, then click on one of these buttons. The text size increases or decreases, becomes bold, italicized or underlined.

Text Alignment & Lists

text alignment
In addition to font styles, you can create ordered lists, numbered lists, decrease or increase indent and change the alignment of the selected text.

Change the Title of the Web Page

In order to change the title of your page:

  1. Go to the menubar and choose Format > Page Title and Properties.
    A dialog box will appear.
  2. In the Title section enter your page title, click OK.

Change the Colors of the Web Page

  1. Go to the menubar and choose Format > Page Colors and Background.
  2. Select Use custom colors.
    page colors for links
  3. Change any of the colors by clicking the color box to the left.
    • Normal Text: text foreground color.
    • Link Text: color used to display hypertext links.
    • Active Link Text: color shown when a user clicks on a hypertext link.
    • Visited Link Text: color used to distinguish hypertext links the user has already visited.
  4. Select a color from the color palette drop down menu.
  5. When done, click OK.

For more help customizing your web page, see some helpful links for Netscape Composer

Step 3 — Inserting an Image & Saving Images from the Web

image icon

Inserting an image onto your page

  1. Place the blinking cursor in the area where the image will go.
  2. Click the image button (shown above).
  3. Under Image Location, click on Choose File....
  4. Select an image to insert from the files on your computer.
  5. Click Open.
  6. Click OK.
The image will appear on your page.

Other Options:

  • To resize the image: Double-click the image. Click Dimensions from the tabs across the top. Make adjustments in the dialog box that appears and click OK.

    Note: The 'constrain' option maintains the width and height proportions when resized so the altered image does not look distorted.

Saving images from the web

Any image found on the web may be saved to your computer. However, it is important to be aware of Copyright Laws.

  1. Place the mouse pointer on top of the image. Right-click (Mac users, click and hold) with the mouse and choose Save Image As....
  2. The name of the file may be changed, but the extension (.gif or .jpg) should NOT be changed.

For more help customizing your web page, see some helpful links for Netscape Composer

Step 4 — Making Tables

table icon

Adding a table

  1. Place the blinking cursor in the area where the table will go.
  2. Click on the table button (shown above).
    • Specify the number of rows and columns.
    • The width of the table may be fixed or set to a percentage of the browser screen size.
    • Enter a border line width. A value of "0", will make the borders invisible when viewed in a browser.
  3. Click OK to add the table.

Modifying a table

  • Change table properties by right clicking on or in the table and choosing "Table Cell Properties".

For more help customizing your web page, see some helpful links for Netscape Composer

Step 5 — Making Links

link icon

Link to a website (URL)

A URL is an internet address, generally beginning with 'http'.
For example: http://www.yahoo.com or http://www.uci.edu

  1. Highlight the text or image which will become your link.
  2. Click on the Link button (shown above).
  3. A dialog box will appear.
  4. Enter the complete URL in the Link Location box.
  5. Click OK.

Link to a local file or picture within your website

  1. Highlight the text or image which will become your link.
  2. Click on the Link button (shown above).
  3. A dialog box appears.
  4. Click Choose File....
  5. Select the file you wish to link to.
  6. Click Open.

Link to specific place within the same page

To link within the same page, create a target, then create a link that points to the target.
This is useful for longer documents or those that contain many sections.

  • Make a target to link to
    1. Place the cursor where you would like the target to be.
    2. Go to Insert > Named Anchor...
    3. Enter a short name, with no spaces, for the target.
    4. Click OK.
    5. A target graphic appears anchor icon, denoting a location which may be linked to.
  • Make a link to the target
    1. Highlight the text or image that will link to the target above.
    2. Click Link.
    3. Click on the dropdown menu arrow down arrow icon, and select a Named Anchor from the popup list.
      (for example: #section1)
    4. Click OK.

Link to an E-mail address

  1. Highlight the text or image which will become your link.
  2. Click Link.
  3. In the Link Location box, enter the following:
       mailto:address@uci.edu
       (where 'address@uci.edu' is the email address you wish to link to)
  4. Click OK.

For more help creating a link, see some helpful links for Netscape Composer

Step 6 — Preview your web page

browse icon

  1. Click on the Browse button shown above.
  2. If you have not already done so, a dialog box will open asking you to save changes.
  3. Click Save....
  4. Click OK.
  5. Your web page will open in Mozilla.
  6. This is how your web page will appear to someone viewing it on the internet.

For more help previewing your web page, see some helpful links for Netscape Composer

Step 7 — Publishing to the Web

publish icon

Netscape 4.79 users:
This documentation is for Netscape 7. Please refer to Creating Course Web Pages with Netscape Composer 4.79

Netscape 6 users:
Netscape 6 does not support any publishing features.
Please download the latest version of Netscape 7 or later.

Netscape 7 users:

  1. Save the file on your computer.
  2. Click Publish (shown above).
  3. Under the Settings Tab, enter the following information:
    • Site Name: Short nickname you want to use for this particular publishing site.
    • Publishing Address: Enter the following text in the box:

      sftp://eee.uci.edu/public_html
    • HTTP address of your homepage: Leave this field blank.
    • User name: The name you use to log into your network. (specified by 5-digit course code,quarter and year, i.e. 99000s03)

      List of quarters:
      • Fall, enter "f".
      • Winter, enter "w".
      • Spring, enter "s".
      • Summer Session 1, enter "y".
      • Summer Session 2, enter "z".
      • Summer Session 10-week, enter "m".
    • Password: The password for your user name.
    • Save Password: This option encrypts and saves your password securely using Password manager.

         For example:
         publish page window

  4. Under the Publish Tab, enter the following information:
    • Site Name: Lists all the publishing sites you've created. Choose the site you want to publish to.
    • Page Title: The document's page title that appears in the browser window's title bar, and also in your list of bookmarks if you bookmark the page.
    • Filename: The document's filename that precedes .html or .htm.

          Warning: If a file on the remote site has the same filename as one you're uploading,
          the newly uploaded file will replace the existing one, without confirmation.
    • Site subdirectory for this page: Leaving this blank will publish the page to the root publishing directory. Otherwise, this specifies the name of the remote subdirectory that is underneath the root directory at this site.

          Note: The site subdirectory must already exist on the remote server.
    • Include images and other files: This option publishes any images and other files referenced by this page in either the same location as the page, or in a remote subdirectory under the root directory.

         For example:
         publish page window

  5. Click Publish.
Your document is now published.

For more help publishing your web page, see some helpful links for Netscape Composer

CONVERTING WORD DOCS TO HTML

Important Note

If you have Word 7.0/95, Word 97, Office 98 or Word 2000, you can make your Word files into Web files by saving them as HTML files. This method also works with Word 6.0 with Internet Assistant (you can download Internet Assistant from the OAC PC Archive located at http://pc.nacs.uci.edu/ or the OAC MAC Archive located at http://mac.nacs.uci.edu/).

Saving Word Documents as HTML

  1. Open the Word Document that you wish to publish.
  2. In the File menu choose the Save As option.
  3. In the Save As dialog box, choose the HTML Document (*.html) or Save as HTML or Save as Web Page option.
    (Be sure you are saving it with all other web site documents on your computer).
  4. This file may now be opened in the Mozilla.
    Use File > Open to open the document.

Note: At this point you might notice that your text looks a little different than it did in Word. The 'Save As HTML' method generally retains much of the formatting in Word, but you may still need to use Mozilla Composer to edit your text into the desired form.